Server Outages
Resolved
Mar 30, 2026 at 7:50pm UTC
We believe that the issue has now been completely resolved. Our cloud provider has shared some information with us regarding this outage: network equipment issues affected the Backbone/Network Core offering, which caused temporary availability issue.
We do not anticipate any further interruptions to our services.
Affected services
Updated
Mar 30, 2026 at 7:33pm UTC
The issue is still ongoing, but is not causing full outages - only partial. We currently have no additional information from our cloud provider. More information will be provided when available.
Affected services
Created
Mar 30, 2026 at 7:26pm UTC
Unfortunately, our cloud provider seems to have some outages at the moment. All services are currently believed to be impacted. More information will be provided when it is available.
Affected services